Some customers unable to upgrade their plans
Incident Report for Autopilot
Resolved
This incident has been resolved.
Posted 3 months ago. Feb 04, 2019 - 14:04 UTC
Investigating
We are currently investigating an issue which is preventing some customers from upgrading their plans. Please contact our support team via LiveChat or email for assistance if required.

We apologise for any inconvenience and hope to have this resolved shortly.
Posted 3 months ago. Feb 04, 2019 - 05:17 UTC
This incident affected: Application.