Some email links are not working
Incident Report for Autopilot Journeys
Resolved
This incident has been resolved.
Posted Nov 18, 2015 - 20:37 UTC
Investigating
We are currently investigating this issue.
Posted Nov 18, 2015 - 20:30 UTC