Task processing delays
Incident Report for Autopilot
Resolved
All delayed tasks have been completed.
Posted about 1 month ago. Jan 11, 2017 - 04:27 UTC
Investigating
We are investigating delays in processing tasks (e.g. adding contacts).
Posted about 1 month ago. Jan 11, 2017 - 00:01 UTC