Email delays
Incident Report for Autopilot
Resolved
We have take action to resolve this and are looking into the root cause. We apologize for the delay.
Posted 4 months ago. Mar 11, 2019 - 14:39 UTC
Investigating
We are investigating delays that we are experiencing in sending email as a priority.
Posted 4 months ago. Mar 11, 2019 - 14:26 UTC