Our email server provider, Sendgrid, is experiencing delays
Incident Report for Autopilot
Resolved
This incident has been resolved.
Posted almost 2 years ago. Oct 31, 2016 - 18:25 UTC
Update
Sendgrid's team has mitigated the issue, and are currently monitoring performance. We’ll provide a final update once this is resolved.
Posted almost 2 years ago. Oct 31, 2016 - 17:17 UTC
Monitoring
See http://status.sendgrid.com/incidents/bgv3yf4v727x

We will provide updates as soon as we know more, however this may cause slower than usual email delivery.
Posted almost 2 years ago. Oct 31, 2016 - 15:20 UTC