Email delivery delays
Incident Report for Autopilot
Resolved
This incident has been resolved.
Posted 9 months ago. Sep 12, 2017 - 14:28 UTC
Identified
Our email server provider, Sendgrid, is experiencing delays processing email. See http://status.sendgrid.com/incidents/3wq6qdxjjb4s for further details. They are working to resolve this as a top priority. We'll provide updates as they are made available to us.
Posted 9 months ago. Sep 12, 2017 - 14:17 UTC