Delays in email event processing
Incident Report for Autopilot
Resolved
This incident has been resolved.
Posted 22 days ago. Nov 21, 2018 - 20:33 UTC
Investigating
We are investigating delays in the processing of email events (e.g. sent, opened and clicked).
Posted 22 days ago. Nov 21, 2018 - 20:13 UTC