Email Delivery Issue

Incident Report for Autopilot Journeys

Resolved

This issue has now been resolved. Thank you for your patience.
Posted Jan 24, 2022 - 18:06 UTC

Identified

We are currently experiencing issues reaching the inboxes of some email receivers and we are working hard to resolve this issue.
Posted Jan 21, 2022 - 19:23 UTC